What are the system requirements to use Spire?

Jonathan Yagel -

Spire works for the iPhone (or iPod Touch) with iOS 8 and up , Android devices with 4.0.3 and later, and any computer with Safari, Chrome, or Firefox. Spire also works on the latest version of Internet Explorer.

An Internet connection is necessary to access Spire.


Have more questions? Submit a request

0 Comments

Article is closed for comments.